Pages: 1
Author Topic: Need help troubleshooting parser error: unable to open DTD document 'null'  (Read 1131 times)

Posts: 1

« on: July 21, 2016, 01:42:20 PM »

I am using XMetal Author Enterprise Version#: with the Authoring Bridge (v12.0.2417.0) for SDL Knowledge Center 2016. I'm pretty new to XMetal, so please forgive any gaps in my knowledge or glaring errors (corrections are greatly appreciated)! I'm using DITA specializations for maps, topics, tasks, etc. Every time I try to insert a topicref into a map, I'm able to successfully select and insert my selected file from the repository, but the navtitle doesn't display in the edit window, and I get the following error message in my Results window:

topicref@href - The referenced element contains invalid markup. - Parser Error: 1: unable to open DTD document 'null'
    @href - GUID-EB8BC3C4-8623-45CF-A54D-FDA88054FBA4

If I select Open Referenced File, the referenced file is successfully opened. If I select Validate Document on the open referenced topic file, it returns a successful validation.

I get the same error message if I attempt to insert a conref into a topic as well. I've confirmed that the content is valid at the location I'm inserting the conref, but the content of the conref is not displayed, and I get the same error message as displayed above.

I have checked the doctype declarations of my map files and my topic files (including the topic files where my conrefs are stored), and they are all valid doctype declarations. I also examined the following items to ensure that the specialized doctypes are correctly configured:

  • {local_xmetal_install_folder}\Author\DITA\XACs\dita_xac_catalog_specialized.xml
  • {local_xmetal_install_folder}\Author\DITA\XACs\{specialized_folders}\{specialized_dtds}
  • {local_xmetal_install_folder}\Author\DITA\{my_doctype_folder}\\{my_doctype_dtd}
  • {local_xmetal_install_folder}\Author\DITA\{my_doctype_folder}\\{my_doctype_mod}

I've confirmed that all of the files related to each specialization are referenced correctly to ensure that the doctype can be found and that it contains valid content. It does.

I'm hoping someone can provide me with some additional troubleshooting steps to try, or if someone else has encountered this issue, the steps they took to resolve it.

Thanks in advance for any assistance or insight!
Pages: 1
Jump to: