Pages: 1
Print
Author Topic: XMetaL 8 DITA-OT temporary files: Can we prevent renaming of files?  (Read 1601 times)
jpcain429
Member

Posts: 5


« on: October 15, 2015, 01:23:55 PM »

Greetings,

We have a primary XML file that references another XML file for references to image files.  In the primary XML file, the image reference is to a print-friendly image file (e.g., eps, indesign, etc).  We have a new transform that generates HTML for online.  Rather than have users manage multiple image file references, our HTML transform simply looks to match a print image file with a similarly named online image file.  This transform works great in a straight-up DITA-OT installation.  However, after configuring this online transform for use within XMetaL, the preprocessing that creates copies of the source files being transformed to a temp folder randomly renames all of the referenced files.  This breaks all of our resulting image file references.  Is it possible to prevent preprocessing from renaming the referenced files?

Thanks,

Jim
Logged
jpcain429
Member

Posts: 5


« Reply #1 on: October 15, 2015, 07:21:25 PM »

Every file, except for the primary file as input to the transform, is renamed.  Is there a way to disable this behavior? 

<log_line>
[echo] All files : C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\Content_09497.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad13659_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad1591C_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad1F58F_tmp.jpg;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad214EF_tmp.jpg;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad2657A_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad2B006_tmp.pdf;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad30B4F_tmp.pdf;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad3F3D7_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad4B058_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad4FAF7_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad6D47F_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad7EA1B_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad882F0_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad882FF_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\rad8AFBD_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radA1FD0_tmp.pdf;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radB6CF2_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radC1A5F_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radE23AA_tmp.indd;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radED2D7_tmp.xml;C:\users\dmadmin\appdata\local\temp\rad304d5.tmp\radca4b5_tmp\radFDC0A_tmp.pdf</log_line>


Thanks,

Jim
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2443



WWW
« Reply #2 on: October 16, 2015, 12:10:56 PM »

If you are running the Japanese edition then this behaviour is normal, and should not be altered if your file names are in Japanese (or non-Latin in general) as the DITA OT cannot handle those characters.

If you are not running the Japanese edition this is not normal. The setting for this must have somehow been enabled.

In either case (Japanese edition or standard edition) you can disable this setting:

1. Tools > Configure Output
2. Switch to the Advanced tab and check for this setting: cmd_fs_sandboxing  =  yes
3. Change the value to no
Logged
jpcain429
Member

Posts: 5


« Reply #3 on: October 16, 2015, 01:16:57 PM »

Hmmm, I checked, but cmd_fs_sandboxing is already set to no.  Output options are below.

cmd_always_open_log  =  no
ANT_OPTS  =  "-Xmx256m"
cmd_fs_sandboxing  =  no
cmd_cms_sandboxing  =  yes
cmd_dita_before_14_compatible  =  no
cmd_dita_ot_per_user_version  =  14
_rem_cmd_synchro_mode  =  2

Does anything else look off?  I checked our custom print_local_<client>.xml and cmd_fs_sandboxing is set to no in that as well.

Any other possible ideas?

Thanks,

Jim
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2443



WWW
« Reply #4 on: October 16, 2015, 05:28:02 PM »

These all look normal for version 8.

You mention that changes have been made to the print_local.xml file. That would be where I think I'd concentrate my efforts.
Can you revert that to a default copy and see what happens?
Logged
jpcain429
Member

Posts: 5


« Reply #5 on: October 20, 2015, 11:04:42 AM »

I set cmd_cms_sandboxing  =  no and the referenced files are no longer getting renamed.  Is there other behavior that depends on this config item being set to "yes"?
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2443



WWW
« Reply #6 on: October 20, 2015, 03:24:32 PM »

That command is comes into play if you are using a CMS that has an integration with XMetaL Author Enterprise.
In my testing (without a CMS installed) it does not rename the files.
Logged
jpcain429
Member

Posts: 5


« Reply #7 on: October 22, 2015, 10:43:12 AM »

We are using the Documentum Webtop integration with XMetaL.  The only change that I made was to set cmd_cms_sandboxing = no.  Once I did that, the output files were no longer getting renamed.
Logged
Pages: 1
Print
Jump to: