Pages: 1
Print
Author Topic: Map Editor Menu/Commands in XMetaL 9 Miniscule  (Read 3492 times)
palmer@dst
Member

Posts: 56


« on: May 24, 2015, 09:30:45 AM »

XMetaL 9.0.0.053 with IE 11

Is there anything that would cause the Map Editor Menu command and items to display in a miniscule font? The actual Map and topicref text display normal size. See attached capture...

Thanks,

RPalmer


* xmetal9_mapeditor_smallmenu.png (18.11 KB, 272x288 - viewed 293 times.)
« Last Edit: May 24, 2015, 09:46:48 AM by palmer@dst » Logged

rpalmer
DST Systems, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #1 on: May 25, 2015, 02:06:30 PM »

The Map Editor is actually using IE which is embedded inside the Resource Manager. It could be that IE's zoom feature is set to a small setting. You might be able to use Ctrl + the mouse scroll wheel to change the size, but in some cases you might need to open IE externally and set it there (I don't have IE 11 to test with).
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #2 on: May 25, 2015, 02:07:58 PM »

Or maybe Microsoft has changed IE 11's behaviour. XMetaL Author Enterprise 9 would not have been tested with IE 11. I think it was tested with IE 9.
Logged
palmer@dst
Member

Posts: 56


« Reply #3 on: May 26, 2015, 06:06:31 AM »

I actually had this same display behavior in XMetaL 6 with IE 8, so was hoping the upgrade to XMetaL 9 with IE11 would fix it. However, on my testing PC (outside our CCMS server environment), with XMetaL 9 and IE11, this issue does not occur. And for others in our CCMS server environment, it does not occur, so must be related to my IE settings/profile. I deleted the browser cookies/history etc., but still happens..

Do you know which IE files I should delete within my C:\Users\name\AppData? I'm assuming they'd rebuild themselves when I restart XMetaL?

Oh - I did try the CTRL+scroll wheel, but that magnified both the miniscule font and the correctly-sized type in the Map Editor so the correctly-sized became way too big. I opened IE and the view settings are at 100%.

Thanks,

RPalmer
« Last Edit: May 26, 2015, 06:19:06 AM by palmer@dst » Logged

rpalmer
DST Systems, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #4 on: May 27, 2015, 02:08:45 PM »

I've only seen the issue where everything in IE is scaled up or down.

I don't know what would cause different portions of the Map Editor to be rendered in different sizes. It sounds to me like a CSS issue that is somehow affecting one portion of the HTML in there and not the other. Assuming the files on your system in our installation have not been altered I can only conclude that your version of IE is somehow choosing to render these things differently, in which case it is possibly an IE 11 bug (nothing can be done) or a limitation (perhaps there is some workaround).

The CSS files are here:
<XMetaL Installation Path>\Author\XMDK\libs\ui\dhtmlx\css\

I wouldn't try changing anything in those files but do check to see that the "last modified date" matches (indicating that they have not been modified):

dhtmlXToolbar.css
last modified: 2013-01-15 @ 14:14:50

dhtmlXTree.css
last modified: 2011-06-09 ‏‎12:46:18

(translate the time to your local format)
Logged
palmer@dst
Member

Posts: 56


« Reply #5 on: May 28, 2015, 10:34:24 AM »

Thanks, Derek -

I checked both those files and the dates are as you listed. 

But since this is a server installation of XMetaL, wouldn't any files in the <XMetaL Installation Path>\Author\ paths impact ALL users, not just me? So far, I'm the only one experiencing the issue, so felt the issue was related to my C:\Users\name\AppData files some how... just not sure what (if anything) to delete...

RPalmer
Logged

rpalmer
DST Systems, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #6 on: May 29, 2015, 02:23:43 PM »

Can't say as I still don't know what the cause is.
However, as you say, I would assume that if everyone is running the same installation it should function identically for all users.
Logged
gcrews
Member

Posts: 265


« Reply #7 on: June 03, 2015, 03:48:47 PM »

I remember running into this a few years back.

Check the Text Size setting in IE:

1. Open IE
2. Open View menu (Alt+V)
3. Expand Text Size sub menu
4. Ensure Medium is selected.

I think that setting only affects text with no CSS font size defined. I bet it will fix small font on web pages you may have occasionally noticed.


* textSize.gif (16.22 KB, 387x407 - viewed 290 times.)
« Last Edit: June 03, 2015, 03:55:57 PM by gcrews » Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #8 on: June 03, 2015, 04:48:04 PM »

Nice find. I can reproduce the issue by doing the opposite (setting it to "smallest"), so that must be it.
« Last Edit: June 03, 2015, 04:55:19 PM by Derek Read » Logged
palmer@dst
Member

Posts: 56


« Reply #9 on: June 04, 2015, 06:29:40 AM »

Aha! Mine was already set to "Medium" so I changed it to "Larger" and that did the trick!

Thanks gcrews!

RPalmer


* xmetal9_mapeditor_largemenu.png (15.47 KB, 294x336 - viewed 279 times.)
Logged

rpalmer
DST Systems, Inc.
Pages: 1
Print
Jump to:  

email us