Pages: 1
Print
Author Topic: Map editor: Possible to turn off auto @navtitle?  (Read 2842 times)
edwardwoodward
Member

Posts: 24


« on: February 17, 2015, 01:24:41 AM »

Hello.

Using Xmetal 9

With regard to this, will there be any change due to the navtitle element being recommended in place of the navtitle attribute?

We thought we would be smart and up-to-date and use the navtitle element, but Xmetal keeps recreating the redundant navtitle attribute, so we end up with both, which we don't want.

Cheers.
« Last Edit: February 17, 2015, 06:42:15 PM by Derek Read » Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: February 17, 2015, 06:48:27 PM »

If you go into Tools > DITA Options you can select the Update Content tab and then uncheck the checkbox marked "topicref" (on the right).
This will stop @navtitle from being populated for <topicref> elements.
Logged
edwardwoodward
Member

Posts: 24


« Reply #2 on: February 18, 2015, 06:24:37 PM »

Thanks. That seems to work for any href in the map.

I don't suppose there's any way to hide the "Untitled Chapter", "Untitled Topic" etc. placeholder that is displayed in Tags On View and Normal View. (It shows up even if a navtitle element is set.)
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #3 on: February 19, 2015, 07:54:28 PM »

You will need to alter some CSS.

Add the following to one of these files (which you need to change depends on your DITA version setting from Tools > DITA Options):
C:\Program Files (x86)\XMetaL 9.0\Author\DITA\XACs\1.1\map\map-base-override.css
C:\Program Files (x86)\XMetaL 9.0\Author\DITA\XACs\1.2\map\map-base-override.css

[class~="map/topicref"]:before{
   content: " ";
}


The other selector that is involved with this shows the @navtitle value when set (so you wouldn't alter it). But in case you did want to change it the selector is this one:


[class~="map/topicref"][navtitle]:before{
   content: " " attr(navtitle) " ";
   display: inline;
}
Logged
edwardwoodward
Member

Posts: 24


« Reply #4 on: February 20, 2015, 01:01:50 AM »

Thanks again, but that doesn't seem to make any difference.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #5 on: February 20, 2015, 04:24:27 PM »

Sorry, I missed the clue "Untitled Chapter" and just zeroed in on "map".
You're working with a bookmap I guess, and in that case you can make overrides in one of these files (depending on DITA version):

C:\Program Files (x86)\XMetaL 9.0\Author\DITA\XACs\1.1\bookmap\bookmap-base-override.css
C:\Program Files (x86)\XMetaL 9.0\Author\DITA\XACs\1.2\bookmap\bookmap-base-override.css

You could also go directly into the main CSS file (which loads all the others that contain the actual CSS settings), bookmap_bookmap.css, and make changes there. The result would be the same.
Logged
edwardwoodward
Member

Posts: 24


« Reply #6 on: February 22, 2015, 05:23:17 PM »

Thanks again.

FYI, the changes to the override files didn't make any difference, but the change to bookmap_bookmap did the trick.
Logged
Pages: 1
Print
Jump to:  

email us