Pages: 1
Print
Author Topic: XMetaL 6 Author Essentials error on launch  (Read 2060 times)
megl
Member

Posts: 6


« on: September 24, 2014, 12:15:47 PM »

I have a user, who upon launching XMetaL 6 essentials, receives the following error:

"the server name or address could not be resolved"

We have tried uninstall/re-install. Any suggestions?
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: September 24, 2014, 12:35:30 PM »

This isn't an error I recognize as something XMetaL Author Essential would raise. I strongly suspect this would be triggered by some form of 3rd party code, either a document-level or application-level customization. Both might be created by your own organization, and the latter would also include CMS integrations or other code written by our partners.

Try the following in this order:

1. Launch the software with the Ctrl key held down. Then answer "yes" when prompted to skip opening the workspace. This will reset the workspace (UI) to defaults and stop it from reloading any documents left open last time it was shut down (if the setting for that is enabled). If this resolves the issue then most likely the problem is with a document-level customization, and most likely in a script loaded by that customization, which might be in an MCR file, CTM file, XFT form, or more complex code (like a DLL / ActiveX control loaded via scripting). The same issue should be reproducible by opening an XML file that uses that customization. So once you know which one it is you can try to debug it.

2. Assume that after uninstalling, some corrupted files or custom files are being left behind. Uninstall XMetaL Author Essential, then remove all folders it might leave behind. The uninstaller will leave any folders or files behind if they were not created by the installer (added or modified after installation). Then reinstall.

3. Assume the problem is with some 3rd party code you are installing that modifies the XMetaL Author Essential installation. In this case you should try uninstalling that 3rd party code (might be a CMS or something else that integrates with XMetaL) using their specific uninstaller, then do #2 above, then reinstall ONLY XMetaL Author Essential to test it. If it works as expected then install the 3rd party code. If at that point things don't work then you need help from whoever made this 3rd party code.
Logged
Pages: 1
Print
Jump to: