Pages: 1
Print
Author Topic: DTD not found error!  (Read 3712 times)
tmakita
Member

Posts: 26



WWW
« on: June 10, 2014, 09:08:48 AM »

Hi,

One of our user reported us that he encountered "DTD not found" error when he opened a DITA task file.

The file is encoded with UTF-8 and has BOM.

Code:
<?xml version="1.0" encoding="UTF-8"?>
<?Pub Inc?>
<!--Arbortext, Inc., 1988-2011, v.4002-->
<!DOCTYPE task PUBLIC "-//OASIS//DTD DITA Task//EN" "task.dtd">

However we cannot reproduce this error in XMetaL 8.0 Japanese + Windows 7 or XMetaL 9.0 English + Windows 7.0 environment.

Is it a known problem?

I know that XMetaL always save new topic file with UTF-8 encoding and that has no BOM mark.

I'm waiting for your reply.

Regards,
Logged

Toshihiko Makita
Development Section
Antenna House, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: June 10, 2014, 02:38:49 PM »

This shouldn't be an issue. If you can provide the file that the user was working with to XMetaL Support they would be happy to test it to see if they can reproduce the issue.

It isn't clear from your message whether this is an ongoing issue for this person. Perhaps it was some kind of temporary glitch.
If the issue persists and you cannot reproduce it I would suggest reinstalling. It could be that the catalog files used for DITA or some other files that make up that part of the DITA authoring experience have been modified, corrupted or removed.
Logged
tmakita
Member

Posts: 26



WWW
« Reply #2 on: June 12, 2014, 05:58:17 AM »

Hi Derek,

> If the issue persists and you cannot reproduce it I would suggest reinstalling.

Yes, you are right.
This user gave me the information that this error occurs for all of the "task" XML files. So the public identifier to DTD mapping in XMetaL may be broken for some reason.

However this user also reported us that re-installing did not solve this problem. XMetal 8 Japanease version still outputs  a error that DTD does not found after re-installing.

Do you have any solutions?

Regards,
Logged

Toshihiko Makita
Development Section
Antenna House, Inc.
tmakita
Member

Posts: 26



WWW
« Reply #3 on: June 12, 2014, 06:27:29 AM »

For your reference, this user is using XMetaL 8 Japanese version with floating licensing on Windows 7/64bit.
Logged

Toshihiko Makita
Development Section
Antenna House, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #4 on: June 12, 2014, 01:18:16 PM »

The installer should overwrite any files it "owns" (any files it installs). I suspect something must be stopping that.

1. Reboot to make sure no files are locked or otherwise cannot be removed by the installer.
2. Uninstall.
3. Remove this folder in case something was left behind: C:\Program Files (x86)\XMetaL 8
4. If you cannot remove that folder and everything it contains then that is the issue. You may need to get your IT people involved to force removal or figure out what has locked any files / folders.
5. Install again.
Logged
Pages: 1
Print
Jump to:  

email us