Pages: 1
Print
Author Topic: topic id's  (Read 5516 times)
ramu
Member

Posts: 33


« on: January 24, 2014, 12:55:19 AM »

Hi,

I have created a topic in teamcenter and edited it in xmetal. Added some content to it. When where i saved it back to teamcenter, the operation fails and in teamcenter it is showing an error like this


 ERROR at line / column: 3 / 19 in file 001053_hqt3erup.xml with the message: Attribute value "001053" of type ID must be an NCName when namespaces are enabled.

so for that I had an answer. In Id, we have to type in the following format: alphabet_numeric(EX:A-123456)


But this has to do for every time. How can we resolve this issue or  how can we have that id automatically.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2618



WWW
« Reply #1 on: January 24, 2014, 03:27:15 PM »

This sounds like a little bit of a complicated mess to unravel...

In DITA, the id attribute for almost all elements is optional and is defined to be CDATA, with the exception of the following elements (which are usually the root element of a DITA document). These elements require an id attribute value and the id attribute is defined as a (true) ID: "topic", "reference", "concept", "task". This leads me to believe that you may be working with a DTD other than DITA, or that Siemens Teamcenter CMS may be complaining about your DITA documents when it should not be, or that you have turned off the feature for our DITA authoring functionality that automatically sets id values for elements. For this last one please see the documentation topic named "DITA options" which discusses the feature "Auto-assign element IDs".

As the error is coming from Teamcenter you may get some good information from Siemens support. At which point we can try to help you to configure XMetaL Author to use the same schema that Teamcenter is using to validate (if it is not DITA), or help your users enter correct attribute values, or help you to automate that process through customization.

It would be very helpful if you could provide more information:
Which version of XMetaL Author Enterprise are you working with?
Which DITA document type is giving you problems?
Having a sample of one of the documents would also probably help. You may wish to open a support case with XMetaL Support and submit files there (and discuss this through email).
Logged
barbwire
Member

Posts: 44


« Reply #2 on: February 04, 2014, 07:08:25 AM »

Hi,

I have created a topic in teamcenter and edited it in xmetal. Added some content to it. When where i saved it back to teamcenter, the operation fails and in teamcenter it is showing an error like this


 ERROR at line / column: 3 / 19 in file 001053_hqt3erup.xml with the message: Attribute value "001053" of type ID must be an NCName when namespaces are enabled.

so for that I had an answer. In Id, we have to type in the following format: alphabet_numeric(EX:A-123456)


But this has to do for every time. How can we resolve this issue or  how can we have that id automatically.

Contact your Teamcenter administrator. He can modify administrative objects, which are needed when modifying for example topic. When using Teamcenter, the id-attribute should be the topic Item ID. There is something wrong either your administrative objects or id itself. Nevertheless: the problem is not in the Xmetal side.
Logged
Pages: 1
Print
Jump to: