Pages: 1
Print
Author Topic: Leading spaces in PDF outputs  (Read 2036 times)
tahnee_m
Member

Posts: 10


« on: August 01, 2013, 01:23:14 PM »

This is a similar problem brought up in the pretty printing affecting HTML outputs discussion here: http://forums.xmetal.com/index.php/topic,3159.0.html

A customer has reported a large number of stray leading spaces in li output when they generate PDFs from our source. When we checked the normalized DITA source, the leading spaces were present. Further investigation of our source revealed that the spaces are present prior to normalization. The quantity, however, was so high that simple author error seemed unlikely. The spaces are visible only in Plain Text view. They are not visible in the XMetaL Tags On view that we recommend writers use, so writers have no idea that the spaces are present. Our writers currently use XMetaL 6.0.

We can’t reliably repeat it, but it seems that when you select text at the beginning of the element and delete it all as one, XMetaL isn’t removing all of the spaces. It also seems that our transforms are ignoring the leading spaces, while the customer’s are not.

So we have two problems:

1.   Deleting isn’t deleting everything.
2.   The styled views are hiding leading spaces, preventing writers from dealing with #1.

Is this something that should be filed as a defect or is there another solution we could investigate? Thanks for any help.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: August 02, 2013, 07:12:34 PM »

DITA documents are "pretty printed" by XMetaL Author Enterprise by default when you save from Tags On or Normal view. If you do not want this additional white-space to be added to your DITA XML source documents you will need to disable the pretty printing feature.

To turn off pretty printing for the DITA authoring solution run the macro titled "DITA Configuration: Turn OFF Pretty-Printing".

The DITA Open Toolkit (both the copy we install with XMetaL Author Enterprise and the one available directly from the SourceForge DITA OT project) handles "insignificant white-space" (what we add for "pretty printing") fine in every case I have seen. I suspect this means your client is either not producing output using the DITA OT, or they have modified the DITA OT so that it is no longer capable of properly dealing with it.
Logged
Pages: 1
Print
Jump to: