Pages: 1
Print
Author Topic: Topleaf error: build_topleaf.xml does not exist  (Read 2816 times)
iweyers
Member

Posts: 9


« on: February 11, 2013, 07:21:53 AM »

Hello,

I recently installed the topleaf plugin to create custom stylesheets for my DITAmaps, but when testing the installation on the XMetaL eveluation guide, I get the following error:

=====
C:\Users\IB61B~1.WEY\AppData\Roaming\SoftQuad\XMETAL~1\DITA_OT>call ant -Dargs.input="c:/users/i.weyers/documents/xmetal/evaluation guide/XMetaL_Evaluator_Guide.ditamap" -Doutput.dir="C:\Users\i.weyers\Documents\XMetaL\Evaluation Guide\pdf_out"   -Ddita.temp.dir=C:\Users\IB61B~1.WEY\AppData\Roaming\SoftQuad\XMETAL~1\DITA_OT\temp -Ddita.dir=C:\Users\IB61B~1.WEY\AppData\Roaming\SoftQuad\XMETAL~1\DITA_OT -Dtksroot=C:\PROGRA~1\TKS -Dtlrepos=C:\PROGRA~2\TopLeaf -Dtlplugin=C:\PROGRA~1\TOPLEA~1 -Dstylesheet=DITAmap -Dpdfprofile=default -Dargs.logdir=C:\Users\IB61B~1.WEY\AppData\Local\Temp\XMetaL\RENDIT~1\log -Ddita.extname=xml -Dargs.indexshow=no -Dargs.artlbl=no -Dargs.draft=yes -Ddita.input.valfile="c:\users\i.weyers\documents\xmetal\evaluation guide\pdf_out\XMetaL_Evaluator_Guide.ditaval"  -f build_topleaf.xml TopLeaf.PDF

Buildfile: build_topleaf.xml does not exist!

Build failed
=====

The "TopLeaf/XMetal how to" guide advises to contact this forum when the test publication does not work, so here I am. Does anyone what went wrong in my installation? I indeed cannot find the specific file on my computer.

Thank you!
Logged
iweyers
Member

Posts: 9


« Reply #1 on: February 11, 2013, 08:24:54 AM »

I tried deleting and rebuilding the DITA-OT folder in SoftQuad. The previously mentioned error no longer occurs, but now I get the following error:

=====
TopLeaf.compose:
[echo] Setting C:\Users\IB61B~1.WEY\AppData\Roaming\SoftQuad\XMETAL~1\DITA_OT\temp\Test.ditamap using style DITAmap</log_line><log_line>
[topleaf.compose] Composition log saved to p:\inge weyers\topleaf\pdf_out\TL_log.txt

BUILD FAILED

C:\Users\IB61B~1.WEY\AppData\Roaming\SoftQuad\XMETAL~1\DITA_OT\build_topleaf.xml:133: Composition failed: error 1039
=====

I searched for the composition log and found there the same error as I also get when trying to compose the DITAMAP template in the TopLeaf GUI:

=====
Repository:    C:\PROGRA~2\TopLeaf
Partition:     DITAmap-Template
Style Sheets:  C:\PROGRA~2\TopLeaf\DITAmap (*.DEF)
Common Files:  C:\Program Files\TKS\common
Font Config:   C:\PROGRA~2\TopLeaf\font.cfg
Job:           C:\Users\IB61B~1.WEY\AppData\Local\Temp\TLApso5
Composed by:   TopLeaf 7.6.32 (7.6.032) at 2013/02/11 14:53:53
Flags:         DOCUMENT,XML(EN),UNICODE,WIN32
Start page:    1


   ERROR: 001 - can't open -
          C:\Work\JustSys\Samples\gendata.ditamap
 IN FILE: C:/PROGRA~2/TopLeaf/DITAmap/pagetypes.def, LINE: 1

   ERROR: 706 - no pages were created
 IN FILE: C:/PROGRA~2/TopLeaf/DITAmap/pagetypes.def, LINE: 1

PROGRAM STATUS
Markers:   0 referenced, 0 defined.
Entities:  0 referenced, 973 defined.
Mappings:  8 referenced, 0 implied, 0 defined, 0 used.
Macros:    1291 referenced, 951 defined, 121 used.
Fonts:     0 used.
Pages:     none (0.0 pages/sec).
Errors:    2 errors, 0 warnings.
Status:    Abnormal program shutdown.

ABNORMAL EXIT
=====

The following file (and location) do not exist in my system: "C:\Work\JustSys\Samples\gendata.ditamap", nor can I find the gendata.ditamap file on any other location in my computer.

I suppose that this is a environment parameter that should not be fixed? Can anyone help me to get further with this issue?

Thank you!

Logged
tonys
JustSystems Partner
Member

Posts: 80


« Reply #2 on: February 11, 2013, 03:28:44 PM »

I've looked at the stylesheet distributed by the plugin and "C:\Work\JustSys\Samples\gendata.ditamap" is the initial value for the input. This means that something is going wrong during the OT processing, and your document is not being loaded. If you can send the log.xml file that XMetaL creates it may explain what is happening.
Logged
Pages: 1
Print
Jump to:  

email us