Pages: 1
Print
Author Topic: How to get over Java Heap space error and use 64 bit java  (Read 2074 times)
Wim Hooghwinkel - iDTP
Member

Posts: 22


« on: December 10, 2012, 04:10:01 AM »

(Win7 64 bit, 8G memory, XMetaL 7)

Hi, I try to publish a ditamap with many conrefs. Using te default OT 1.6.3 and FOP I can generate a PDF. I have my system parameters set to JAVA_OPTS=6000m and use 64 bit JRE (global environment variable points to the JRE 7 path C:\Program Files\Java\jre7).

In XMetal I get the Jave Heap space error after 22 seconds.

In  the configure output dialogs I have added JAVA_OPTS=6000m and ANT_Opts=-Xmx6000m (also tried ANT_OPTS=-Xmx2400m as that seems to be the maximum for ANT) and in the logfile I can see the corresponding lines, so these settings are taken I presume.

But in the logfile I also see the lines:
set path= C:\Program Files (x86)\Java\jre7\bin
set JAVA_HOME=C:\PROGRA~2\COMMON~1\XMETAL~1\jre1.5.0

Question: where do these settings come from. It seems like XMetal is not using the 64 bit Java in C:\Program Files\Java\jre7?

Or should i set Java memory in another place?

Thanks ....

Wim Hooghwinkel

add:

Sorry, I just read Dereks answer to my previous post (must have missed that ...) and will try this first:

XMetaL can use an alternate version of JRE if you want to try it. We only test using JRE 1.5 however and we know everything works with it and can't recommend any other version. If you have tested with another JRE and know it works then presumably it would be OK.

You can try the following:

Tools > Configure Output > Advanced (tab) and then in the "Other output parameters" section add the following:
JAVA_HOME  =  C:\your_java_folder

Specify the folder containing your copy of Java, not the path to the executable (java.exe).

When you generate output you should see that value being set in the DITA output log (opened in XMetaL as log.xml if you have it configured to open the log file).
« Last Edit: December 10, 2012, 04:14:32 AM by Wim Hooghwinkel - iDTP » Logged

W
Pages: 1
Print
Jump to: