Pages: 1
Print
Author Topic: Fatal error in Japanese configuration in XMetaL7.0  (Read 2412 times)
tmakita
Member

Posts: 26



WWW
« on: April 10, 2012, 12:22:55 AM »

Dear Forum members,

I found fatal configuration problems using XMetaL 7.0 for Japanese PDF output. If an user outputs Japanese content PDF tha Japanese character does not appear at all. I fixed it by following. I wish next servise pack contains these fixes otherwise XMetaL will miss Japanese user!

1. xmfo font configuration
C:\Users\[User Name]\AppData\Roaming\SoftQuad\XMetaL Shared\DITA_OT\demo\xmfo\cfg\fo\font-mappings.xml

This configuration file does not use popular Japanese font installed in C:\Windows\Fonts. "KozMinProVI-Regular" is a font that comes with Adobe Reader. The most popular font in Japanese Windows are "MS-Gothic" and "MS-MIncho".

<logical-font name="Sans">
  <physical-font char-set="Japanese">
    <font-face>KozMinProVI-Regular</font-face>
  </physical-font>
  ...
</logical-font>

This should be:
<font-face>MS-Gothic</font-face>

<logical-font name="Serif">
  <physical-font char-set="Japanese">
    <font-face>KozMinProVI-Regular</font-face>
  </physical-font>
  ...
</logical-font>

This should be:
<font-face>MS-Mincho</font-face>

<logical-font name="Monospaced">
  <physical-font char-set="Japanese">
    <font-face>KozMinProVI-Regular</font-face>
  </physical-font>
  ...
</logical-font>

This should be also:
<font-face>MS-Gothic</font-face>

2. XMetaL xmfo customization mistake

C:\Users\[User Name]\AppData\Roaming\SoftQuad\XMetaL Shared\DITA_OT\demo\xmfo\Customization\fo\attrs\xm-cfg\commons-attr.xsl

All of the spaces in <xsl:attribute>..</xsl:attribute> must be removed.

<xsl:attribute-set name="topic.title">
  <xsl:attribute name="font-family"> <xsl:value-of select="$xm.title.font-family"/> </xsl:attribute>
  ...
</xsl:attribute-set>

This *MUST* be:

<xsl:attribute-set name="topic.title">
  <xsl:attribute name="font-family"><xsl:value-of select="$xm.title.font-family"/></xsl:attribute>
  ...
</xsl:attribute-set>

Otherwise proper font substitution for Japanese will not be done. (This is the bug from XMetaL6.0 version.)

3. XEP configuration

XEP is not configured to use Japanese fonts in C:\Windows\Fonts.

The following font *MUST* be added.

<font-group xml:base="file:/C:/Windows/Fonts/" label="Windows TrueType" embed="true" subset="true">
  ...
  <font-family name="MS-Mincho">
    <font>
      <font-data ttf="msmincho.ttc"/>
    </font>
  </font-family>
  <font-family name="MS-Gothic">
    <font>
      <font-data ttf="msgothic.ttc"/>
    </font>
  </font-family>
  ...
</font-group>

I hope this helps!

Regards,

Logged

Toshihiko Makita
Development Section
Antenna House, Inc.
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: April 10, 2012, 10:47:03 AM »

The 6.0 Japanese edition ships with these types of changes. It also installs special fonts that can be embedded into PDF files (though clients are free to change these settings as you have done if they wish to embed alternate fonts into their PDF files). A Japanese edition of 7.0 has not been created yet. You have the "regular" release.

I will pass your suggestion along to the development team so they can decide if they want to put these types of changes into the regular release. I am not sure what the plans are for a 7.0 Japanese edition yet.

Note that previous versions of the DITA OT did not handle file names containing non-ASCII characters very well. If a path contained a Japanese character the DITA OT would fail to produce output. So, you may also need to enable the following setting (this is enabled by default in the 6.0 Japanese edition).

Tools > Configure Output > Advanced (tab)
cmd_fs_sandboxing  =  yes

This setting is set to "no" in the regular release. When enabled, and you are working with the local file system (and not a CMS with a proper XMetaL connector installed) it tells XMetaL Author Enterprise to make a copy of your input files, change all file names to use ASCII characters only, and fix up all links accordingly. Once that is done the new copy of your input files is passed on to the DITA OT for processing.

I am not sure if that is necessary with the current version of the DITA OT that comes with XMetaL Author Enterprise 7.0 (version 1.5.4).
« Last Edit: April 10, 2012, 03:08:52 PM by Derek Read » Logged
Pages: 1
Print
Jump to:  

email us