Pages: 1
Print
Author Topic: Extra spaces in lists cause problems  (Read 4778 times)
robsfl
Member

Posts: 6


« on: February 24, 2009, 03:23:46 AM »

Hello to All! We are using Xmetal for editing DITA files and have run into two really basic problem that cause some havoc. They are not related, so I post separately.

Xmetal includes extra spaces in lists that carry paragraphs, i.e. there will often be an extra space between an <li> an a following <p>, and vice versa. Is there a way to clean these out? After converting the files using DITA OT, it messes up the formatting of the lists.

This seems like a minor fault but I have not found a solution - any help would be really great!

Logged
robsfl
Member

Posts: 6


« Reply #1 on: February 27, 2009, 07:45:15 AM »

Solved. I found a little application called ElegantXML by Benjamin Fitch which runs over all files in a directory and removes extra spaces.

Of course, I have to repeat that every time I need a PDF output. It would seem that Xmetal should provide such a function somewhere.
Logged
mag3737
XMetaL Evangelist
Administrator
Member

Posts: 117

I even use XMetaL to write my business letters.


« Reply #2 on: February 27, 2009, 01:25:16 PM »

Could this be fixed by turning off the "pretty-printing" in the DITA customization?  Go to Tools > Macros, find and run the macro for "Turn OFF Pretty Printing".  You'll need to restart XMetaL, and then run that helper app on the files one more time before opening them in XMetaL.  (You could also fix the spaces manually in XMetaL's Plain Text View after you've turned off pretty-printing and restarted XMetaL.)
« Last Edit: February 27, 2009, 04:22:39 PM by Derek Read » Logged

Tom Magliery
JustSystems Canada, Inc.
robsfl
Member

Posts: 6


« Reply #3 on: March 02, 2009, 07:47:43 AM »

Thanks for the extra hint, I will try that.
Logged
Pages: 1
Print
Jump to: