Pages: 1
Print
Author Topic: TOPLEAF: Table Heads Not Repeating after Page Break  (Read 2683 times)
palmer@dst
Member

Posts: 56


« on: July 15, 2011, 02:19:55 PM »

In the TopLeaf Page Layout, I'm using the standard 1 column page, with the Enable automatic table heads option set for all pages (which are mirrored and have different headers/footers than the default 1 column page), and the Table headers settings on the Options tab is set to All columns. In the Map Manager, my $document Table settings are the same as the default DITAmap-Template, and my table is nested in a <p>, which is set to Inherit current table style in the Map Manager. I'm using a CALS table with table heading (thead) tags. The table heads appear on just the first page of the table, but when the table breaks a page, no table heads (or even a top horizontal line on the first row of the new page).

If I run the table in the DITAmap-Template, the heading rows do repeat okay.

Any thoughts?

Thanks,

RP
Logged

rpalmer
DST Systems, Inc.
gjn2066
Member

Posts: 60


WWW
« Reply #1 on: August 29, 2011, 06:37:15 PM »

Sounds as though you are doing everything OK. Have you enabled the table heads on the specific page type you are using when this happens, as each page type has its own set of options.

PS: JustSystems has asked Turn-Key to participate directly in the forums, so you can expect faster responses from now on.
Logged
gjn2066
Member

Posts: 60


WWW
« Reply #2 on: September 14, 2011, 10:19:00 PM »

Had a look at your stylesheet. In File>>Partiton Properties>>Looseleaf you have the Blank Back selector set to 1 column.

This has the effect of declaring that your standard single column page type should be used in the This page intentionally blank role. This in turn cancels all flow on effects such as continuation headers, table heads etc. for that page type.

If you set the Blank Back to {implied} you will restore normal operation.
Logged
palmer@dst
Member

Posts: 56


« Reply #3 on: September 15, 2011, 10:57:02 AM »

Excellent. That worked! In my version of TopLeaf (7.5.018) the Initial Page Type - Blank Back setting was on the Format tab instead of the Looseleaf tab, but it worked regardless of the location.

Thanks much,

RP
Logged

rpalmer
DST Systems, Inc.
Pages: 1
Print
Jump to: