Pages: 1
Print
Author Topic: Dropping apostrophes from French text  (Read 1603 times)
MaskedBit
Member

Posts: 1


« on: June 20, 2011, 02:59:00 PM »

We have an application that works with a variety of languages.  The XML content is displayed through a set of forms in XMetaL 6.0.  The original content contains apostrophes, as in  Si l'émetteur est acquis lors d'une opération.  In XMetaL, however, the apostrophes are not being displayed.  If I edit the document without changing the content of the form, the apostrophes are not touched.  However, if I edit the content being displayed in the form, then save the file, the apostrophes are gone.  To continue the example:  Si lémetteur est acquis lors dune opération.
Is there a language or formatting setting that might be causing this?
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2568



WWW
« Reply #1 on: June 20, 2011, 03:29:25 PM »

When you say "form" I assume you are referring to an XFT form that is part of your customization. That is the first place I would look. Check to see that a programming error (in the form itself) has not been made, or if no special programming has been done you might need to add some to handle this case.

Keep in mind that the controls you place on an XFT form may also have specific quirks for handling the display of particular characters. None of the standard controls we include for building XFT forms have any built-in functionality for dealing with XML (and very few controls do in case you are using 3rd party controls) so it is very possible that some script code has been added to deal with this entity (or entities in general).

Without seeing the XFT form, the DTD and a sample XML file there isn't much more I can add. If you didn't create this XMetaL customization yourself then you may wish to contact the creator and ask them if they can debug the issue and add missing code to handle this or fix code that is not doing what you expect.
Logged
Pages: 1
Print
Jump to: