Pages: 1
Print
Author Topic: Xrefs display Short Description from target topics in pdf- how to exclude these?  (Read 3443 times)
jepry
Member

Posts: 19


« on: March 15, 2011, 01:59:29 PM »

I've searched the forum and don't see any answer to this:

Xrefs I create in DITA show up in a published PDF with the short description text from the target topic printed where I placed the xref.

Is there a way to exclude these?

Using XMetaL(R) Author Enterprise 6.0.1

Update:

Just to clarify: Using XMetal Author Enterprise 6.0.1, right out of the box, when I create a cross reference in a DITA topic to another DITA topic, then when I generate a PDF using the built-in Render X XEP output, the link text in the resulting .pdf is followed by the Short Description text from the target topic.

So if my xref is pointing to "Target Topic", and the target topic contains a short description after the topic title that reads "Here is a short description", then on my generated PDF, the link to that topic, in blue text, reads:

 "Target TopicHere is a short description", exactly that way, with no space between the two.

Since this seems to be the default behavior, I'm puzzled that others haven't come across it often, but I see no references to it anywhere.

From experience with DITA using other editing tools, I understand that the short description is picked up to be included under related links in HTML output, so this is obviously something about the PDF output that's putting them also just in any cross reference. Without getting heavily into style sheets, isn't there a way to simply turn this off? Or any way to fix it at all would be good.

Thanks,
« Last Edit: March 16, 2011, 06:58:00 AM by jepry » Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: March 16, 2011, 06:29:42 PM »

I am unable to reproduce this issue here with an unmodified installation of 5.1, 5.5 and 6.0 and we have no reports from other clients similar to this.

You are using the deliverable type called "XMetaL Enhanced PDF via RenderX XEP" and you are sure the installation has not been modified?

I have attached my test case along with the PDF that is produced: xref_pdf_test.zip

* xref_pdf_test.zip (6.6 KB - downloaded 266 times.)
« Last Edit: March 16, 2011, 06:53:37 PM by Derek Read » Logged
jepry
Member

Posts: 19


« Reply #2 on: March 16, 2011, 09:41:41 PM »

Thanks for the reply, this seems to have been caused by a corrupt topic, we discovered after lots of chasing it down. I finally rebuilt the topic using exactly the same xml but with a newly-generated topic and the links started behaving. 

The problematic topic was the target of the link, not the source. And yes, using XMetaL Enhanced PDF via RenderX XEP which otherwise was working fine, and is now for this one too.

All's well that ends well.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #3 on: March 16, 2011, 09:51:28 PM »

If you still have a copy of the topic that triggers the behavior I would be interested to see it as I don't understand how this could occur. It might be useful to log this as a defect with the DITA OT project. If you don't want to post it here you may submit it to support@xmetal.com
Logged
Pages: 1
Print
Jump to: