Pages: 1
Print
Author Topic: Error in Document Type Declaration in the document  (Read 3782 times)
kwag_myers
Member

Posts: 69


« on: January 18, 2011, 02:16:21 PM »

I think I broke something...again. I was playing around with this: http://forums.xmetal.com/index.php/topic,431.msg1720.html#msg1720 in an effort to get My Assets going (it's a slow day here in the mire). Anyway, in Windows 7, the only way to edit the XMetaL60.ini file is to change some permissions. I couldn't get it to work, but now when I attempt to open a file in XMetaL it opens in Plain Text View with an error:

"Error in Document Type Declaration in the document: Unable to create rules file. The file C:\Program Files (x86)\XMetaL 6.0\Author\DITA\XACs\concept\concept_ditabase.rlx could not be created."

I've tried changing everything back the way it was (to the best of my recollection) and restarting my machine. Any suggestions (besides the obvious: stop playing with stuff you know nothing about)?
Logged

XMetaL 6 Author in Windows 7 Home Premium
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: January 18, 2011, 04:03:34 PM »

Actually, you can add options to the following file and they should override (cumulatively) settings inside the copy installed next to XMetaL60.exe:

%appdata%\SoftQuad\XMetaL\6.0\xmetal60.ini

Having said that, I suspect your issue is that you have removed the following setting that tells XMetaL you are running as a user with less than full permission to write files anywhere you like (the default behavior of Windows XP):

user_setting_mode=per_user

This is set by default and will be required on almost any version of Windows 7 (where people are usually "limited users"). If you log in as a local admin and turn UAC off you can get away without having it installed. With this setting enabled XMetaL writes any files it would otherwise write to a read only location (such as C:\Program Files) into the following "per user" location instead (which is what you want): %appdata%\SoftQuad\XMetaL\6.0\gen\<recreate original path to file>

« Last Edit: January 18, 2011, 04:05:25 PM by Derek Read » Logged
kwag_myers
Member

Posts: 69


« Reply #2 on: January 19, 2011, 07:19:25 AM »

Ah, I see the problem - underscore, not hyphen. Su-Laine Yeo has "...per-user..." in her (previously mentioned) post. Changing the hyphen to an underscore has solved the issue. I should also mention that this was causing XMetaL to go unresponsive on closing. This, too, has been resolved.

Thanks again.
Logged

XMetaL 6 Author in Windows 7 Home Premium
Su-Laine Yeo
Solutions Consultant
Member

Posts: 260


« Reply #3 on: January 19, 2011, 01:13:34 PM »

Sorry about the hyphen vs. underscore mixup. I've just corrected it in the original post. Thanks for catching this.

Su-Laine
Logged

Su-Laine Yeo
Solutions Consultant
JustSystems Canada, Inc.
Pages: 1
Print
Jump to: