Pages: 1
Print
Author Topic: title wrapping  (Read 3499 times)
gcrews
Member

Posts: 265


« on: November 30, 2010, 11:06:01 AM »

Xmetal seems to keep wrapping long titles. When just using tag view the title seems ok, but in code view or in notepad there are line returns and tabs in the title tag. When we generate a CHM the compiled hhc ends up with thes line returns to witch then place   box characters in the CHM toc. I’m probably going to go tweak the toolkit but it would be nice if Xmetal did not add the line returns to the tag.  Is there some way to change the behavior of the title tag to act like a pre tag or something?

-Thanks in advance
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #1 on: November 30, 2010, 12:43:48 PM »

The easiest thing to do would be to turn of Pretty Printing.
See this post: http://forums.xmetal.com/index.php/topic,1104.0.html

Logged
gcrews
Member

Posts: 265


« Reply #2 on: November 30, 2010, 03:36:58 PM »

Thanks, Yeah I found that after a bit of poking around. I looked at the ctm files and I can’t tell what is different about the pre and title prettyprintingoptions. I’m guessing Xmetal has some specific built in handling of pre and screen.
Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2621



WWW
« Reply #3 on: November 30, 2010, 03:58:03 PM »

If pretty printing is turned on the default line wrapping width (aka: max line length) is 80 characters and indenting is 2 spaces. For DITA we set <MaxLineLength> to 80 characters in the CTM file so it is the same as the default setting. If you don't mind messing with the CTM file you could have Pretty Printing on but make the <MaxLineLength> value bigger.

Pretty Printing has a general section at the top of the CTM file, but then each element also has its own section where you can set things up for each element. There is a setting you can use to override the <MaxLineLength> on an element by element basis called <IgnoreMaxLineLength/>. The only element this is set for in the 6.0 releases is imagemap.
Logged
gcrews
Member

Posts: 265


« Reply #4 on: November 30, 2010, 06:37:26 PM »

Thank you, <IgnoreMaxLineLength  /> worked like a charm, I had tried <NoPrettyPrinting /> before with no luck. Pre seems to ignore the pretty printing regardless though; Xmetal must have a specific case for a few elements.
Logged
Pages: 1
Print
Jump to:  

email us