Pages: 1
Print
Author Topic: Opening xml files in xmetal takes time  (Read 2627 times)
chandan7891
Member

Posts: 23


« on: November 24, 2010, 03:26:54 AM »

Hi All,

I am very much new to XMetal and i am trying to open XML file (2.61 MB) file and its taking long time to open (more than 30 secs). My system configuration is as :
RAM - 3 GB
Processor - Core2Duo 2.00 GHz
 So just want to confirm that is it the ususal XMetal Author  5.5 behaviour because of that its taking long time to open file or i need to make some changes at my end.

Any help will be appreciated. Thanks..
Logged
gcrews
Member

Posts: 265


« Reply #1 on: November 24, 2010, 10:17:30 AM »

We have 3 800kb+ maps that I edit in the xml viewer. Thankfully I only have to edit them twice a year mainly. There are 2 things that I do that helps performance a lot. Disabling the “check spelling while typing” helps a lot for me. With it enabled practically every time I do anything the CPU goes 100% for about 30 seconds, with it disabled it doesn’t do that. I also found that tag view is a lot quicker than normal view. Of course this is just with DITA, I don’t know how  things behaving in non DITA files.
« Last Edit: November 24, 2010, 10:19:56 AM by gcrews » Logged
Derek Read
Program Manager (XMetaL)
Administrator
Member

Posts: 2606



WWW
« Reply #2 on: November 25, 2010, 05:50:03 PM »

I can see how turning the "check spelling while typing" feature off in XMetaL Author Enterprise 6.0 might help. The 6.0 release was the first version to include this feature and it was not really well optimized and can affect the rendering speed (that work is happening now for the next release).

Unfortunately, this particular suggestion isn't going to help chandan7891 as the 5.5 release didn't have this feature.

grews: You will likely be happy to note that test versions I've seen recently show that we're making really noticeable improvements in this area, and the feature in general is being reworked to improve it in other aspects.
Logged
Pages: 1
Print
Jump to:  

email us