Pages: 1
Print
Author Topic: Debug Javascript Code displayed in XMetaL 6 Resource Manager  (Read 2572 times)
freyp576
Member

Posts: 7


« on: October 18, 2010, 03:31:52 AM »

Hi

we currently have some troubles with Javascript code not working if run from a web page displayed in the XMetaL 6 Resource Manager (running XMetaL v6.0.1.030).

The code works fine if running outside XMetaL in a standalone Webbrowser (IE 8.0.6700.16385)
so it is not a IE / javascript problem. In our script we use

        var xmetal = new ActiveXObject("XMetaL.Application");

and use it to access the XMetaL API.

We checked also the Internet Options / Advanced settings, and options:

Disable script debugging (Internet Explorer)
Disable script debugging (Other)

Both options are unchecked, i.e. script debugging enabled.
And we do stop at debugger statements in our javascript code if run in standalone webbrowser.

So we assume it has to do with the Webbrowser control.

Question: how can we enable script debugging (for either IE Developer tools, or Visual Studio 2008 Debugger) for the Webbrowser control?
Logged
freyp576
Member

Posts: 7


« Reply #1 on: November 11, 2010, 09:20:18 AM »

Update, I was successful in the meantime. I had to log off the windows session, then start Visual Studio in advance, and now debugging works, i.e. the Visual Studio / Javascript debugger stopps on the hardcoded 'debugger' statements in our webpages displayed in the ResourceManager/webbrowser control

(strange thing that it did not work before, indeed)
Logged
Pages: 1
Print
Jump to:  

email us